Instalasi news

Langkah pertama yang harus kita lakukan adal merubah kofigurasi Apache server kita dan mengaktifkan modul Rewrite URL. Caranya adalah sebagai berikut:

  1. cari file httpd.conf dengan fasilitas search windows. Di komputer penulis letaknya adalah di C:AppServApache2.2conf
  2. edit dengan text editor dan cari #LoadModule rewrite_module modules/mod_rewrite.so
  3. aktifkan dengan cara menghilangkan tanda # sehingga menjadi
    LoadModule rewrite_module modules/mod_rewrite.so
    mod rewrite url
  4. simpan
  5. restart Apache Server dengan cara klik Start | All Programs | AppServ | Control Server by Service | Apache Restart
  6. Tapi lebih baik apabila Anda restart komputer Anda. Caranyanya udah tahu khan???ūüėÄ

Langkah ke dua adalah mengextract file sNews15.zip hasil download ke direktori www di server Anda. Ada kemungkinan Anda harus meletakkan di direktori htdocs apabila anda menggunakan paket instalasi selain AppServ, misalnya XAMPS.
Pada kasus ini penulis menggunakan Appserv yang direktorinya berada di C:AppservwwwsNews15

isi file snews

Langkah ke tiga adalah membuat database untuk CMS kita. Caranya adalah sebagai berikut:

  1. Buka browser dan arahkan ke localhost/phpmyadmin
  2. isi username dan password (user dan password sesuai saat instalasi AppServ)
  3. buat database baru dengan mengisikan nama database dan klik create
    buat database snews
  4. Klik SQL untuk memasukkan kode sql kita.
    klik sql
  5. klik readme.html yang isinya petunjuk instalasi dan sql untuk database kita
  6. Kemudian copy kode sql ini: (lebih baik copy dari file readme.html saja)
    1. CREATE TABLE articles (
    2. id int(11) primary key auto_increment,
    3. title varchar(100) default NULL,
    4. seftitle varchar(100) default NULL,
    5. `text` longtext,
    6. `date` datetime default NULL,
    7. category¬†int(8)¬†NOT¬†NULL¬†default ‘0’,
    8. position int(6) default NULL,
    9. displaytitle¬†char(3)¬†NOT¬†NULL¬†default ‘YES’,
    10. displayinfo¬†char(3)¬†NOT¬†NULL¬†default ‘YES’,
    11. commentable varchar(5) NOT NULL default ,
    12. published¬†int(3)¬†NOT¬†NULL¬†default ‘1’,
    13. description_meta varchar(255) default NULL,
    14. keywords_meta varchar(255) default NULL
    15. );CREATE TABLE categories (
    16. id int(8) primary key auto_increment,
    17. name varchar(100) NOT NULL,
    18. seftitle varchar(100) NOT NULL,
    19. description varchar(255) NOT NULL,
    20. published¬†varchar(4)¬†NOT¬†NULL¬†default ‘YES’,
    21. catorder¬†smallint(6)¬†NOT¬†NULL¬†default ‘0’
    22. );CREATE TABLE comments (
    23. id int(11) primary key auto_increment,
    24. articleid¬†int(11)¬†default ‘0’,
    25. name varchar(50),
    26. url varchar(100) NOT NULL,
    27. comment text,
    28. time¬†datetime¬†NOT¬†NULL¬†default ‘0000-00-00¬†00:00:00’,
    29. approved¬†varchar(5)¬†NOT¬†NULL¬†default ‘True’
    30. );CREATE TABLE settings (
    31. id int(8) primary key auto_increment,
    32. name varchar(20) NOT NULL,
    33. `value` varchar(60) NOT NULL
    34. );¬†¬†INSERT¬†INTO¬†settings¬†VALUES¬†(1,¬†‘website_title’, ‘sNews¬†1.5’);
    35. INSERT¬†INTO¬†settings¬†VALUES¬†(2,¬†‘home_sef’, ‘home’);
    36. INSERT¬†INTO¬†settings¬†VALUES¬†(3,¬†‘website_description’, ‘sNews¬†CMS’);
    37. INSERT¬†INTO¬†settings¬†VALUES¬†(4,¬†‘website_keywords’, ‘new,¬†site,¬†snews’);
    38. INSERT¬†INTO¬†settings¬†VALUES¬†(5,¬†‘website_email’, ‘info@mydomain.com’);
    39. INSERT¬†INTO¬†settings¬†VALUES¬†(6,¬†‘contact_subject’, ‘Contact¬†Form’);
    40. INSERT¬†INTO¬†settings¬†VALUES¬†(7,¬†‘language’, ‘EN’);
    41. INSERT¬†INTO¬†settings¬†VALUES¬†(8,¬†‘charset’, ‘UTF-8’);
    42. INSERT¬†INTO¬†settings¬†VALUES¬†(9,¬†‘date_format’, ‘d.m.Y.¬†H:i’);
    43. INSERT¬†INTO¬†settings¬†VALUES¬†(10,¬†‘article_limit’, ‘3’);
    44. INSERT¬†INTO¬†settings¬†VALUES¬†(11,¬†‘rss_limit’, ‘5’);
    45. INSERT¬†INTO¬†settings¬†VALUES¬†(12,¬†‘display_page’, );
    46. INSERT¬†INTO¬†settings¬†VALUES¬†(13,¬†‘display_new_on_home’, );
    47. INSERT¬†INTO¬†settings¬†VALUES¬†(14,¬†‘display_pagination’, );
    48. INSERT¬†INTO¬†settings¬†VALUES¬†(15,¬†‘num_categories’, ‘on’);
    49. INSERT¬†INTO¬†settings¬†VALUES¬†(16,¬†‘approve_comments’, );
    50. INSERT¬†INTO¬†settings¬†VALUES¬†(17,¬†‘comments_order’, ‘ASC’);
    51. INSERT¬†INTO¬†settings¬†VALUES¬†(18,¬†‘comment_limit’, ’30’);
    52. INSERT¬†INTO¬†settings¬†VALUES¬†(19,¬†‘word_filter_enable’, );
    53. INSERT¬†INTO¬†settings¬†VALUES¬†(20,¬†‘word_filter_file’, );
    54. INSERT¬†INTO¬†settings¬†VALUES¬†(21,¬†‘word_filter_change’, );
    55. INSERT¬†INTO¬†settings¬†VALUES¬†(22,¬†‘username’, ‘098f6bcd4621d373cade4e832627b4f6’);
    56. INSERT¬†INTO¬†settings¬†VALUES¬†(23,¬†‘password’, ‘098f6bcd4621d373cade4e832627b4f6’);

    CREATE TABLE articles ( id int(11) primary key auto_increment, title varchar(100) default NULL, seftitle varchar(100) default NULL, `text` longtext, `date` datetime default NULL, category int(8) NOT NULL default ‘0’, position int(6) default NULL, displaytitle char(3) NOT NULL default ‘YES’, displayinfo char(3) NOT NULL default ‘YES’, commentable varchar(5) NOT NULL default ”, published int(3) NOT NULL default ‘1’, description_meta varchar(255) default NULL, keywords_meta varchar(255) default NULL );CREATE TABLE categories ( id int(8) primary key auto_increment, name varchar(100) NOT NULL, seftitle varchar(100) NOT NULL, description varchar(255) NOT NULL, published varchar(4) NOT NULL default ‘YES’, catorder smallint(6) NOT NULL default ‘0’ );CREATE TABLE comments ( id int(11) primary key auto_increment, articleid int(11) default ‘0’, name varchar(50), url varchar(100) NOT NULL, comment text, time datetime NOT NULL default ‘0000-00-00 00:00:00’, approved varchar(5) NOT NULL default ‘True’ );CREATE TABLE settings ( id int(8) primary key auto_increment, name varchar(20) NOT NULL, `value` varchar(60) NOT NULL ); INSERT INTO settings VALUES (1, ‘website_title’, ‘sNews 1.5’); INSERT INTO settings VALUES (2, ‘home_sef’, ‘home’); INSERT INTO settings VALUES (3, ‘website_description’, ‘sNews CMS’); INSERT INTO settings VALUES (4, ‘website_keywords’, ‘new, site, snews’); INSERT INTO settings VALUES (5, ‘website_email’, ‘info@mydomain.com’); INSERT INTO settings VALUES (6, ‘contact_subject’, ‘Contact Form’); INSERT INTO settings VALUES (7, ‘language’, ‘EN’); INSERT INTO settings VALUES (8, ‘charset’, ‘UTF-8’); INSERT INTO settings VALUES (9, ‘date_format’, ‘d.m.Y. H:i’); INSERT INTO settings VALUES (10, ‘article_limit’, ‘3’); INSERT INTO settings VALUES (11, ‘rss_limit’, ‘5’); INSERT INTO settings VALUES (12, ‘display_page’, ”); INSERT INTO settings VALUES (13, ‘display_new_on_home’, ”); INSERT INTO settings VALUES (14, ‘display_pagination’, ”); INSERT INTO settings VALUES (15, ‘num_categories’, ‘on’); INSERT INTO settings VALUES (16, ‘approve_comments’, ”); INSERT INTO settings VALUES (17, ‘comments_order’, ‘ASC’); INSERT INTO settings VALUES (18, ‘comment_limit’, ’30’); INSERT INTO settings VALUES (19, ‘word_filter_enable’, ”); INSERT INTO settings VALUES (20, ‘word_filter_file’, ”); INSERT INTO settings VALUES (21, ‘word_filter_change’, ”); INSERT INTO settings VALUES (22, ‘username’, ‘098f6bcd4621d373cade4e832627b4f6’); INSERT INTO settings VALUES (23, ‘password’, ‘098f6bcd4621d373cade4e832627b4f6’);

  7. Paste di phpMyAdmin.
    run query sql sNews
  8. Klik Go
  9. Setelah proses selesai maka database Anda sudah siap.

Langkah ke empat adalah mengubah konfigurasi CMS kita. Letaknya di file snews.php. Langkah-langkahnya adalah sebagai berikut:

  1. Buka file snews.php di text editor kita
  2. Cari kode berikut dan ubah sesuai konfigurasi server kita
    1. // DATABASE VARIABLES
    2. function db($variable) {
    3. $db = array();
    4. $db[‘website’]¬†= http://localhost/sNews15/’;
    5. $db[‘dbhost’]¬†= ‘localhost’; //MySQL¬†Host
    6. $db[‘dbname’]¬†= ‘snews’; //Database¬†Name
    7. $db[‘dbuname’]¬†= ‘username’; //Database¬†Username
    8. $db[‘dbpass’]¬†= ‘password’; //Database¬†password
    9. $db[‘prefix’]¬†= ; //Database¬†prefix
    10. $db[‘dberror’]¬†=¬†‘<strong>There¬†was¬†an¬†error while connecting¬†to¬†the¬†database.</strong>¬†<br¬†/>
    11. Check¬†your¬†database¬†settings.’;¬†//Database¬†error¬†message
    12. # session fingerprint password (hardcoded variant)
    13. $db[‘secretWord’]¬†= ‘my_secret_word’; //¬†Default¬†session¬†password¬†(make¬†it¬†hard¬†to¬†guess¬†and¬†change¬†it¬†often)
    14. return $db[$variable];
    15. }

    // DATABASE VARIABLES function db($variable) { $db = array(); $db[‘website’] = ‘http://localhost/sNews15/&#8217;; $db[‘dbhost’] = ‘localhost’; //MySQL Host $db[‘dbname’] = ‘snews’; //Database Name $db[‘dbuname’] = ‘username’; //Database Username $db[‘dbpass’] = ‘password’; //Database password $db[‘prefix’] = ”; //Database prefix $db[‘dberror’] = ‘<strong>There was an error while connecting to the database.</strong> <br /> Check your database settings.’; //Database error message # session fingerprint password (hardcoded variant) $db[‘secretWord’] = ‘my_secret_word’; // Default session password (make it hard to guess and change it often) return $db[$variable]; }

  3. Untuk kasus kita, kita ubah sebagai berikut:
    1. // DATABASE VARIABLES
    2. function db($variable) {
    3. $db = array();
    4. $db[‘website’]¬†= http://localhost/sNews15/&#8217;;
    5. $db[‘dbhost’]¬†= ‘localhost’; //MySQL¬†Host
    6. $db[‘dbname’]¬†= ‘snews15’; //Database¬†Name
    7. $db[‘dbuname’]¬†= ‘root’; //Database¬†Username
    8. $db[‘dbpass’]¬†= ‘passwordku’; //Database¬†password
    9. $db[‘prefix’]¬†= ; //Database¬†prefix
    10. $db[‘dberror’]¬†= ‘<strong>There¬†was¬†an¬†error¬†while¬†connecting¬†to¬†the¬†database.</strong>¬†<br¬†/>¬†Check¬†your¬†database¬†settings.’; //Database¬†error¬†message
    11. # session fingerprint password (hardcoded variant)
    12. $db[‘secretWord’]¬†= ‘terserah_aja’; //¬†Default¬†session¬†password¬†(make¬†it¬†hard¬†to¬†guess¬†and¬†change¬†it¬†often)
    13. return $db[$variable];
    14. }

    // DATABASE VARIABLES function db($variable) { $db = array(); $db[‘website’] = ‘http://localhost/sNews15/&#8217;; $db[‘dbhost’] = ‘localhost’; //MySQL Host $db[‘dbname’] = ‘snews15’; //Database Name $db[‘dbuname’] = ‘root’; //Database Username $db[‘dbpass’] = ‘passwordku’; //Database password $db[‘prefix’] = ”; //Database prefix $db[‘dberror’] = ‘<strong>There was an error while connecting to the database.</strong> <br /> Check your database settings.’; //Database error message # session fingerprint password (hardcoded variant) $db[‘secretWord’] = ‘terserah_aja’; // Default session password (make it hard to guess and change it often) return $db[$variable]; }

  4. jangan lupa kasih tanda “/” sesudah alamat website kita

    $db[‘website’] = ‘http://localhost/sNews15/&#8217;;

  5. Setelah diubah, simpan.
  6. CMS kita siap dicoba

Langkah ke lima; mencoba CMS kita

  1. Buka browser kita, misalnya Internet Explorer.
  2. Ketik alamat CMS kita: localhost/snews15
  3. Tekan enter dan upz….. ternyata begini tampilannya di Internet Explorer
    internet explorer error
  4. jangan panik dulu, mungkin IEnya yang error seperti punya penulis.
  5. Coba browser lain, misalnya Opera atau Mozilla Firefox
  6. Ternyata tidak ada masalah. Dan muncul tampilan sederhana Snews1.5
    snews 1.5 di Opera 9.10
  7. Apabila muncul peringatan seperti ini:
    There was an error while connecting to the database.
    Check your database settings.

    berarti konfigurasi Anda belum benar, dan edit lagi.
  8. Klik login kemudian isikan
    Username: test
    Password: test
    dan hasil penjumlahan 2 integer
  9. Masuk ke halaman Admin

DNS Server Fedora Linux

Membuat DNS Server, Web Server dan Database Server Menggunakan Linux Fedora 8

Server Linux Fedora 8DNS Server dan LAMP menggunakan Linux Fedora sebenarnya pernah saya tuliskan pada artikel saya yang terdahulu, tentang DNS Server Linux, Web Server Linux. Dengan tujuan membantu rekan-rekan yang baru saja beralih ke Linux dan kebetulan menggunakan Linux Fedora 8, ada baiknya saya menuliskan artikel ini. Panduan ini untuk kasus sebagai berikut:

  1. Membuat DNS server untuk domain linuxer.local
  2. Membuat DNS server virtual untuk domain fxekobudi.local, sarolangun.local
  3. Membuat Web server untuk domain linuxer.local, fxekobudi.local, dan sarolangun.local
  4. Membuat Database server menggunakan MySQL yang akan digunakan oleh aplikasi open source (WordPress, Joomla, dan Drupal) pembangun situs lokal pada domain yang telah saya sebutkan di atas.

Sebelum mulai melangkah ke konfigurasi DNS dan LAMP (Linux-Apache-PHP-MySQL), berikut ini adalah konfigurasi pada Laptop yang saya gunakan:

IP Loopback: 127.0.0.1
IP Address NIC: 192.168.0.44
Netmask: 255.255.255.192 (/26)

Paket BIND: bind-9.5.0-18.a7, bind-libs-9.5.0-18.a7, bind-utils-9.5.0-18.a7, bind-chroot-9.5.0-18.a7
Paket APACHE: httpd-2.2.6-3, httpd-tools-2.2.6-3, system-config-httpd-1.4.4-1, httpd-manual-2.2.6-3
Paket MySQL: mysql-libs-5.0.45-4.fc8, mysql-5.0.45-4.fc8, mysql-server-5.0.45-4.fc8
Paket PHP: php-common-5.2.4-3, php-5.2.4-3, php-gd-5.2.4-3, php-cli-5.2.4-3, php-mysql-5.2.4-3

Semua paket sudah disertakan dalam DVD Installer Fedora 8, jadi jika belum terinstal, silahkan instal dengan menggunakan media DVD atau bisa juga menggunakan repository Fedora 8. Untuk mengecek apakah sudah terinstal atau belum, gunakan command: $ rpm -qa | grep [nama-paket]

1. DNS SERVER
Instal paket:
# yum install bind bind-libs bind-utils bind-chroot

Tidak seperti pada fedora 7, Anda dapat menemukan named.conf setelah instalasi bind. Sehingga hanya perlu mengedit konfigurasinya saja.

# vim /var/named/chroot/etc/named.conf

options {
listen-on port 53 { 127.0.0.1; };
listen-on-v6 port 53 { ::1; };
directory ‚Äú/var/named‚ÄĚ;
dump-file ‚Äú/var/named/data/cache_dump.db‚ÄĚ;
statistics-file ‚Äú/var/named/data/named_stats.txt‚ÄĚ;
memstatistics-file ‚Äú/var/named/data/named_mem_stats.txt‚ÄĚ;
allow-query { localhost; };
recursion yes;
};

logging {
channel default_debug {
file ‚Äúdata/named.run‚ÄĚ;
severity dynamic;
};
};

zone ‚Äú.‚ÄĚ IN {
type hint;
file ‚Äúnamed.ca‚ÄĚ;
};

include ‚Äú/etc/named.rfc1912.zones‚ÄĚ;

// ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ-
// Resolve DNS
// ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ-
zone ‚Äúlinuxer.local‚ÄĚ IN {
type master;
file ‚Äú./zone/linuxer.local.zone‚ÄĚ;
allow-update { key ‚Äúrndckey‚ÄĚ; };
allow-transfer { 192.168.0/26; };
};

// ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ-
// Reverse DNS
// ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ-
zone ‚Äú0.168.192.in-addr.arpa‚ÄĚ IN {
type master;
file ‚Äú./zone/0.168.192.in-addr.arpa.zone‚ÄĚ;
allow-update { key ‚Äúrndckey‚ÄĚ; };
allow-transfer { 192.168.0/26; };
};

include ‚Äú/etc/named.primary.conf‚ÄĚ;

Isi file /var/named/chroot/var/named/zone/linuxer.local.zone:

$ttl 38400
@ IN SOA ns.linuxer.local. root.linuxer.local (
1196006770
10800
3600
604800
38400 )
IN NS fxekobudi.linuxer.local.
IN MX 20 mail.linuxer.local.
fxekobudi IN A 192.168.0.44
www IN CNAME fxekobudi
ftp IN CNAME fxekobudi

Isi file /var/named/chroot/var/named/zone/0.168.192.in-addr.arpa.zone:

$ttl 38400
@ IN SOA ns.linuxer.local. root.linuxer.local (
1196006769
10800
3600
604800
38400 )
IN NS fxekobudi.linuxer.local.
44 IN PTR fxekobudi.linuxer.local.

Konfigurasi untuk file /var/named/chroot/etc/named.primary.conf:
# vim /var/named/chroot/etc/named.primary.conf

// ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ-
// Virtual Domain fxekobudi.local
// ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ-
zone ‚Äúfxekobudi.local‚ÄĚ IN {
type master;
file ‚Äú./zone/fxekobudi.local.zone‚ÄĚ;
allow-update { key ‚Äúrndckey‚ÄĚ; };
allow-transfer { 192.168.0/26; };
};

// ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ-
// Virtual Domain sarolangun.local
// ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ‚ÄĒ-
zone ‚Äúsarolangun.local‚ÄĚ IN {
type master;
file ‚Äú./zone/sarolangun.local.zone‚ÄĚ;
allow-update { key ‚Äúrndckey‚ÄĚ; };
allow-transfer { 192.168.0/26; };
};

Isi file /var/named/chroot/var/named/zone/fxekobudi.local.zone:

$ttl 38400
@ IN SOA ns.linuxer.local. root.linuxer.local (
1196006770
10800
3600
604800
38400 )
IN NS fxekobudi.fxekobudi.local.
IN MX 20 mail.fxekobudi.local.
fxekobudi IN A 192.168.0.44
www IN CNAME fxekobudi
ftp IN CNAME fxekobudi

Isi file /var/named/chroot/var/named/zone/sarolangun.local.zone:

$ttl 38400
@ IN SOA ns.linuxer.local. root.linuxer.local (
1196006770
10800
3600
604800
38400 )
IN NS fxekobudi.sarolangun.local.
IN MX 20 mail.sarolangun.local.
fxekobudi IN A 192.168.0.44
www IN CNAME fxekobudi
ftp IN CNAME fxekobudi

Konfigurasi untuk file /etc/resolv.conf:
search linuxer.local
search fxekobudi.local
search sarolangun.local
nameserver 127.0.0.1
nameserver 192.168.0.44

Tes konfigurasi DNS server:
$ dig linuxer.local
$ nslookup http://www.linuxer.local

Jalankan daemon DNS server untuk runlevel yang diinginkan:
# /sbin/chkconfig ‚Äďlevels 235 named on

2. WEB SERVER
Instal paket:
# yum install httpd
Edit file konfigurasi apache:
# vim /etc/httpd/conf/httpd.conf
Berikut beberapa konfigurasi yang perlu Anda lakukan:

### Section 1: Global Environment
User apache
Group apache

### Section 2: ‚ÄėMain‚Äô server configuration
DocumentRoot ‚Äú/var/www/html‚ÄĚ
<Directory ‚Äú/var/www/html‚ÄĚ>
DirectoryIndex index.html index.html.var index.php

### Section 3: Virtual Hosts
# Konfigurasi virtual host
Include ./conf/vhosts.conf

Buat file virtual host:
# vim /etc/httpd/conf/vhosts.conf

NameVirtualHost 192.168.0.44:80

<VirtualHost 192.168.0.44:80>
ServerAdmin admin@linuxer.local
DocumentRoot /var/www/html
ServerName linuxer.local
ServerAlias http://www.linuxer.local
ErrorLog logs/error_log
CustomLog logs/access_log combined
</VirtualHost>

<VirtualHost 192.168.0.44:80>
ServerAdmin admin@linuxer.local
DocumentRoot /var/www/html/fxekobudi
ServerName fxekobudi.local
ServerAlias http://www.fxekobudi.local
ErrorLog logs/fxekobudi.local-error_log
CustomLog logs/fxekobudi.local-access_log combined
</VirtualHost>

<VirtualHost 192.168.0.44:80>
ServerAdmin admin@linuxer.local
DocumentRoot /var/www/html/sarolangun
ServerName sarolangun.local
ServerAlias http://www.sarolangun.local
ErrorLog logs/sarolangun.local-error_log
CustomLog logs/sarolangun.local-access_log combined
</VirtualHost>

Jalankan daemon web server untuk runlevel yang diinginkan:
# /sbin/chkconfig ‚Äďlevels 235 httpd on

3. DATABASE SERVER
Instal paket:
# yum install mysql-libs mysql mysql-server
Jalankan daemon mysql server untuk runlevel yang diinginkan:
# /sbin/chkconfig ‚Äďlevels 235 mysqld on

Gunakan phpMyAdmin untuk mempermudah administrasi. Baca artikel saya tentang instalasi phpMyAdmin.
Buat user selain root untuk mengakses database, gunakan interface phpMyAdmin saja.

4. PHP
Instal paket:
# yum install php-common php php-gd php-mysql
Untuk edit file php.ini, gunakan command berikut:
vim /etc/php.ini
Pada bagian
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
; Error handling and logging ;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
Rubah pada baris 356:
display_errors = On

Pada baris 619, tambahkan extension=gd.so agar script php dapat memanggil modul gd yang akan digunakan untuk Joomla:

;;;;;;;;;;;;;;;;;;;;;;
; Dynamic Extensions ;
;;;;;;;;;;;;;;;;;;;;;;
extension=gd.so

Popularity: 71%

Membuat DataBase dan Tabel pada Apache 2.4.2 Untuk PHP

Apakah anda sering bermain dengan PHP? Apakah anda sering mendengar atau bahkan menggunakan software Apache sebagai DataBase pada PHP? Kalau anda sudah sering menggunakan maka tidak ada salahnya kita berbagi ilmu kepada teman-teman kita. Kalau anda belum pernah sama sekali ayo kita sama-sama mempelajari bagaimana cara membuat DataBase dan Tabel pada software DataBase ini.

Hal yang pertama kali yang harus anda miliki adalah software Apache yang sudah terinstall pada komputer anda. Kalau anda belum punya aplikasinya, bisa di download di om GOOGLE dengan memasukkan kata kunci ‚ÄúDownload Apache‚ÄĚ maka anda akan bisa mendownload software Apache-nya.

Nah apabila anda sudah mempunyai software Apache maka sekarang kita pelajari bagaimana cara membuat DataBase dan Tabel pada Apache tersebut.

1. Jalankan aplikasi Apache anda dengan cara masuk ke Start > All Program > AppServ > Apache Control Server > Start.

2. Setelah Apache dijalankan, maka anda harus mengecek apakah Apache anda sudah betul-betul jalan atau tidak dengan cara masuk ke jendela Internet Explorer dan ketikkan perintah ‚ÄúLocalhost‚ÄĚ. Perhatikan gambar berikut ini :

3. Apabila Apache anda sudah jalan maka setelah mengetikkan localhost akan tampil halaman apache seperti gambar berikut ini :

4. Nah setelah tampil halaman seperti gambar diatas berarti Apache anda sudah berjalan. Sekarang saatnya membuat DataBase dan Tabel untuk project kita kali ini.

5. Untuk membuat DataBase dan Tabel pada Apache ada dua cara yang bisa dilakukan.

a. Klik Link phpMyAdmin Database Manager Version 2.6.0-pl2. Perhatikan gambar berikut :

b. Kalau anda tidak mau menggunakan cara diatas maka gunakan cara ini. Ketikkan langsung pada Address bar disamping localhost-nya ‚ÄúphpMyAdmin‚ÄĚ. Perhatikan gambar berikut :

6. Kalau sudah maka akan tampil halaman untuk membuat DataBase dan Tabel seperti gambar berikut ini :

Pada gambar diatas terdapat kotak untuk mengisi Nama DataBase anda kemudian klik tombol Create. Apache yang saya gunakan menggunakan bahasa Inggris. Kalau anda ingin mengunakan bahasa Indonesia maka tinggal diganti pada bagian Language sebelah kanan.

7. Setelah anda meng-klik tombol Create maka akan tampil gambar seperti ini :

8. Kemudian akan tampil halaman seperti gambar berikut. Nah disini anda memasukkan field-field tabel anda. Perhatikan gambar :

9. Setelah selesai maka akan tampil gambar seperti ini yang menandakan bahwa anda sudah berhasil membuat tabel pada Database Apache.

Selamat anda sudah mempunyai satu tabel pegawai yang bisa anda gunakan pada pemrograman PHP. Selamat mencoba.

MiKroTik

Tutorial Mikrotik

Langkah-langkah berikut adalah dasar-dasar setup mikrotik yang dikonfigurasikan untuk jaringan
sederhana sebagai gateway server.

1. Langkah pertama adalah install Mikrotik RouterOS pada PC atau pasang DOM.

2. Login Pada Mikrotik Routers melalui console :
MikroTik v2.9.7
Login: admin <enter>
Password: (kosongkan) <enter>

Sampai langkah ini kita sudah bisa masuk pada mesin Mikrotik. User default adalah admin
dan tanpa password, tinggal ketik admin kemudian tekan tombol enter.

3. Untuk keamanan ganti password default
[admin@Mikrotik] > password
old password: *****
new password: *****
retype new password: *****
[admin@ Mikrotik]] >

4. Mengganti nama Mikrotik Router, pada langkah ini nama server akan diganti menjadi ‚ÄúXAVIERO‚ÄĚ (nama ini sih bebas2 aja mo diganti)
[admin@Mikrotik] > system identity set name=XAVIERO
[admin@XAVIERO] >

5. Melihat interface pada Mikrotik Router
[admin@XAVIERO] > interface print
Flags: X – disabled, D – dynamic, R – running
# NAME TYPE RX-RATE TX-RATE MTU
0 R ether1 ether 0 0 1500
1 R ether2 ether 0 0 1500
[admin@XAVIERO] >

6. Memberikan IP address pada interface Mikrotik. Misalkan ether1 akan kita gunakan untuk koneksi ke Internet dengan IP 192.168.0.1 dan ether2 akan kita gunakan untuk network local kita dengan IP 172.16.0.1

[admin@XAVIERO] > ip address add address=192.168.0.1
netmask=255.255.255.0 interface=ether1
[admin@XAVIERO] > ip address add address=172.16.0.1
netmask=255.255.255.0 interface=ether2

7. Melihat konfigurasi IP address yang sudah kita berikan
[admin@XAVIERO] >ip address print
Flags: X – disabled, I – invalid, D – dynamic
# ADDRESS NETWORK BROADCAST INTERFACE
0 192.168.0.1/24 192.168.0.0 192.168.0.63 ether1
1 172.16.0.1/24 172.16.0.0 172.16.0.255 ether2
[admin@XAVIERO] >

8. Memberikan default Gateway, diasumsikan gateway untuk koneksi internet adalah 192.168.0.254
[admin@XAVIERO] > /ip route add gateway=192.168.0.254

9. Melihat Tabel routing pada Mikrotik Routers
[admin@XAVIERO] > ip route print
Flags: X – disabled, A – active, D – dynamic,
C – connect, S – static, r – rip, b – bgp, o – ospf
# DST-ADDRESS PREFSRC G GATEWAY DISTANCE INTERFACE
0 ADC 172.16.0.0/24 172.16.0.1 ether2
1 ADC 192.168.0.0/26 192.168.0.1 ether1
2 A S 0.0.0.0/0 r 192.168.0.254 ether1
[admin@XAVIERO] >

10. Tes Ping ke Gateway untuk memastikan konfigurasi sudah benar
[admin@XAVIERO] > ping 192.168.0.254
192.168.0.254 64 byte ping: ttl=64 time<1 ms
192.168.0.254 64 byte ping: ttl=64 time<1 ms
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 0/0.0/0 ms
[admin@XAVIERO] >

11. Setup DNS pada Mikrotik Routers
[admin@XAVIERO] > ip dns set primary-dns=192.168.0.10 allow-remoterequests=no
[admin@XAVIERO] > ip dns set secondary-dns=192.168.0.11 allow-remoterequests=no

12. Melihat konfigurasi DNS
[admin@XAVIERO] > ip dns print
primary-dns: 192.168.0.10
secondary-dns: 192.168.0.11
allow-remote-requests: no
cache-size: 2048KiB
cache-max-ttl: 1w
cache-used: 16KiB
[admin@XAVIERO] >

13. Tes untuk akses domain, misalnya dengan ping nama domain
[admin@XAVIERO] > ping yahoo.com
216.109.112.135 64 byte ping: ttl=48 time=250 ms
10 packets transmitted, 10 packets received, 0% packet loss
round-trip min/avg/max = 571/571.0/571 ms
[admin@XAVIERO] >

Jika sudah berhasil reply berarti seting DNS sudah benar.

14. Setup Masquerading, Jika Mikrotik akan kita pergunakan sebagai gateway server maka agar client computer pada network dapat terkoneksi ke internet perlu kita masquerading.
[admin@XAVIERO]> ip firewall nat add action=masquerade outinterface=
ether1 chain:srcnat
[admin@XAVIERO] >

15. Melihat konfigurasi Masquerading
[admin@XAVIERO]ip firewall nat print
Flags: X – disabled, I – invalid, D – dynamic
0 chain=srcnat out-interface=ether1 action=masquerade
[admin@XAVIERO] >

Setelah langkah ini bisa dilakukan pemeriksaan untuk koneksi dari jaringan local. Dan jika berhasil berarti kita sudah berhasil melakukan instalasi Mikrotik Router sebagai Gateway server. Setelah terkoneksi dengan jaringan Mikrotik dapat dimanage menggunakan WinBox
yang bisa di download dari Mikrotik.com atau dari server mikrotik kita.

Misal Ip address server
mikrotik kita 192.168.0.1, via browser buka http://192.168.0.1 dan download WinBox dari situ.
Jika kita menginginkan client mendapatkan IP address secara otomatis maka perlu kita setup dhcp server pada Mikrotik. Berikut langkah-langkahnya :

1.Buat IP address pool
/ip pool add name=dhcp-pool ranges=172.16.0.10-172.16.0.20

2. Tambahkan DHCP Network dan gatewaynya yang akan didistribusikan ke client Pada contoh ini networknya adalah 172.16.0.0/24 dan gatewaynya 172.16.0.1
/ip dhcp-server network add address=172.16.0.0/24 gateway=172.16.0.1

3. Tambahkan DHCP Server ( pada contoh ini dhcp diterapkan pada interface ether2 )
/ip dhcp-server add interface=ether2 address-pool=dhcp-pool

4. Lihat status DHCP server
[admin@XAVIERO]> ip dhcp-server print
Flags: X – disabled, I – invalid
# NAME INTERFACE RELAY ADDRESS-POOL LEASE-TIME ADD-ARP
0 X dhcp1 ether2
Tanda X menyatakan bahwa DHCP server belum enable maka perlu dienablekan terlebih dahulu pada langkah 5.

5. Jangan Lupa dibuat enable dulu dhcp servernya
/ip dhcp-server enable 0

kemudian cek kembali dhcp-server seperti langkah 4, jika tanda X sudah tidak ada berarti sudah aktif.

6. Tes Dari client
c:\>ping www.yahoo.com

untuk bandwith controller, bisa dengan sistem simple queue ataupun bisa dengan mangle
[admin@XAVIERO] queue simple> add name=Komputer01
interface=ether2 target-address=172.16.0.1/24 max-limit=65536/131072
[admin@XAVIERO] queue simple> add name=Komputer02
interface=ether2 target-address=172.16.0.2/24 max-limit=65536/131072
dan seterusnya…

Entri ini ditulis oleh Yoyok Riawan dan dikirimkan oleh Juli 13, 2007 at 2:46 pm dan disimpan di bawah Mikrotik, Networking. Tandai permalink. Telusuri setiap komentar di sini dengan RSS feed kiriman ini. Tulis komen atau tinggalkan trackback: URL Trackback.

¬ę SETTING¬†MICROTIK

Hak akses root dengan¬†sudo ¬Ľ

Statment Koneksi ke phpmyadmin

MySQL merupakan salah satu DBMS open source yang paling populer pada saat ini. Meskipun dahulu MySQL pernah dikritisi karena tidak memiliki beberapa fitur yang ada dalam DBMS pada umumnya, namun saat ini MySQL sudah banyak dikembangkan.

Koneksi PHP ke MySQL

Sebelum kita melakukan koneksi ke MySQL ada beberapa parameter yang harus kita ketahui terlebih dahulu. Untuk melakukan koneksi, dibutuhkan:

– Server name, merupakan nama server atau no. IP server dimana MySQL tersebut diinstall
– Username, merupakan nama user yang diberikan wewenang untuk mengakses database dalam MySQL
– Password, merupakan password yang dimiliki username dalam rangka autentifikasi.
– Database name, merupakan nama database dalam MySQL yang ingin kita akses.

Untuk memperoleh informasi parameter di atas, dapat menghubungi server administrator. Sedangkan perintah PHP untuk melakukan koneksi ke MySQL adalah
<?php
mysql_connect(“nama server”, “username”, “password”) or die(mysql_error());
echo “Koneksi ke MySQL Sukses<br>”;
Baca lebih lanjut